System Status

Welcome to the Endicia System Status page, our home for real-time information on service alerts. If there are any interruptions in service, a note will be posted here.

Subscribing to Email & SMS Updates—Please “confirm” your subscription by responding to the email we send after you sign up for alerts. This email will be coming from noreply@statuspage.io. To receive alert texts on your mobile phone, you will also need to reply back “YES” to the text confirmation.

Data Processing Delays - Reporting Tools Affected
Incident Report for Endicia Status page
Resolved
Endicia Engineers have fixed the technical issue and all systems are functioning normally. Thanks for your patience!
Posted 21 days ago. Oct 01, 2019 - 09:34 PDT
Identified
Our data processing infrastructure is running behind which is causing inaccuracies in the reporting tools. No data has been lost and the system should be caught up shortly.
Posted 21 days ago. Oct 01, 2019 - 08:13 PDT
This incident affected: Endicia Reporting Tools (Postage History, Refunds, SCAN Forms).