System Status

Welcome to the Endicia System Status page, our home for real-time information on service alerts. If there are any interruptions in service, a note will be posted here.

Subscribing to Email & SMS Updates—Please “confirm” your subscription by responding to the email we send after you sign up for alerts. This email will be coming from noreply@statuspage.io. To receive alert texts on your mobile phone, you will also need to reply back “YES” to the text confirmation.

Unexpected Technical Problem on Orders Page
Incident Report for Endicia Statuspage
Resolved
This incident has been resolved.
Posted Dec 22, 2022 - 12:48 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 22, 2022 - 12:09 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Dec 22, 2022 - 12:06 PST
Investigating
Endicia is currently experiencing a technical issue that we are working to resolve. Our engineering team is working to resolve this issue and will provide an update when it is available. We apologize for the inconvenience.
Posted Dec 22, 2022 - 11:53 PST
This incident affected: Endicia Online (Printing postage using a Web Browser).