System Status

Welcome to the Endicia System Status page, our home for real-time information on service alerts. If there are any interruptions in service, a note will be posted here.

Subscribing to Email & SMS Updates—Please “confirm” your subscription by responding to the email we send after you sign up for alerts. This email will be coming from noreply@statuspage.io. To receive alert texts on your mobile phone, you will also need to reply back “YES” to the text confirmation.

Endicia printing errors
Incident Report for Endicia Statuspage
Resolved
This incident has been resolved.
Posted Jan 30, 2024 - 11:13 PST
Update
Engineers are continuing to investigate an issue that is returning an error when attempting to print postage to non contiguous states. An update will be provided once the root cause has been identified.
Posted Jan 30, 2024 - 09:09 PST
Investigating
Endicia engineers are aware of an issue prompting users to update their software when attempting to print to non-contiguous US states or territories. We are currently investigating and will provide updates when available.
Posted Jan 30, 2024 - 06:57 PST
This incident affected: Endicia Online (Printing postage using a Web Browser), Endicia Downloadable (Print postage using our Windows application), Endicia DAZzle (Print postage with downloadable software for the PC), and Endicia API (Endicia Label Server).