System Status

Welcome to the Endicia System Status page, our home for real-time information on service alerts. If there are any interruptions in service, a note will be posted here.

Subscribing to Email & SMS Updates—Please “confirm” your subscription by responding to the email we send after you sign up for alerts. This email will be coming from noreply@statuspage.io. To receive alert texts on your mobile phone, you will also need to reply back “YES” to the text confirmation.

Unexpected Technical Problem with Etsy on Orders Page
Incident Report for Endicia Statuspage
Resolved
Endicia Engineers have fixed the issue with Etsy and all orders should import normally, a refresh may be required. We apologize for the inconvenience and thank you for your patience. If you are still experiencing an issue please contact our customer support.
Posted Apr 28, 2023 - 15:40 PDT
Update
Endicia Engineers have identified an issue that may affect importing orders and connecting to Etsy on the Orders page. We are working to quickly resolve this issue and will provide an update when it is available. We apologize for the inconvenience.
Posted Apr 19, 2023 - 14:08 PDT
Investigating
Endicia Engineers have identified an issue that may affect importing orders and connecting to Etsy on the Orders page. We are working to quickly resolve this issue and will provide an update when it is available. We apologize for the inconvenience.
Posted Apr 11, 2023 - 11:28 PDT
This incident affected: Endicia Online (Printing postage using a Web Browser).