System Status

Welcome to the Endicia System Status page, our home for real-time information on service alerts. If there are any interruptions in service, a note will be posted here.

Subscribing to Email & SMS Updates—Please “confirm” your subscription by responding to the email we send after you sign up for alerts. This email will be coming from noreply@statuspage.io. To receive alert texts on your mobile phone, you will also need to reply back “YES” to the text confirmation.

Customer unable to print or purchase postage
Incident Report for Endicia Status page
Resolved
Endicia Engineers have fixed the postage printing issue and all systems are functioning normally. Thanks for your patience!
Posted 25 days ago. Sep 27, 2019 - 15:58 PDT
Investigating
We are currently investigating reports of customers unable to print or purchase postage. We apologize for any inconvenience this may be causing you. Our Engineering team is currently investigating this reported behavior.
Posted 25 days ago. Sep 27, 2019 - 09:34 PDT
This incident affected: Endicia Online (Printing postage using a Web Browser), Endicia Downloadable (Print postage using our Windows application), Endicia DAZzle (Print postage with downloadable software for the PC), and Endicia API (Endicia Label Server).