System Status

Welcome to the Endicia System Status page, our home for real-time information on service alerts. If there are any interruptions in service, a note will be posted here.

Subscribing to Email & SMS Updates—Please “confirm” your subscription by responding to the email we send after you sign up for alerts. This email will be coming from noreply@statuspage.io. To receive alert texts on your mobile phone, you will also need to reply back “YES” to the text confirmation.

Unexpected Technical Problem
Incident Report for Endicia Status page
Resolved
Endicia Engineers have fixed the technical issue and all systems are functioning normally. Thanks for your patience!
Posted 15 days ago. Apr 03, 2019 - 08:34 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 15 days ago. Apr 03, 2019 - 08:29 PDT
Identified
The issue has been identified and a fix is being implemented. Thanks for your patience!
Posted 15 days ago. Apr 03, 2019 - 07:44 PDT
Investigating
Endicia is currently experiencing a technical issue that we are working to resolve. Our engineering team is working to resolve this issue as quickly as possible. We'll share another update shortly.
Posted 15 days ago. Apr 03, 2019 - 07:12 PDT
This incident affected: Endicia API (Endicia Label Server).