System Status

Welcome to the Endicia System Status page, our home for real-time information on service alerts. If there are any interruptions in service, a note will be posted here.

Subscribing to Email & SMS Updates—Please “confirm” your subscription by responding to the email we send after you sign up for alerts. This email will be coming from noreply@statuspage.io. To receive alert texts on your mobile phone, you will also need to reply back “YES” to the text confirmation.

History Page Load/Export Issues

Incident Report for Endicia Statuspage

Resolved

This incident has been resolved.
Posted Mar 03, 2025 - 08:25 PST

Identified

We are aware that some customers are having issues loading and exporting their print history on the Endicia web application. Endicia engineers are investigating the situation and will provide an update as soon as one is available.
Posted Feb 28, 2025 - 08:17 PST
This incident affected: Endicia Reporting Tools (Postage History, Refunds, SCAN Forms).