System Status

Welcome to the Endicia System Status page, our home for real-time information on service alerts. If there are any interruptions in service, a note will be posted here.

Subscribing to Email & SMS Updates—Please “confirm” your subscription by responding to the email we send after you sign up for alerts. This email will be coming from noreply@statuspage.io. To receive alert texts on your mobile phone, you will also need to reply back “YES” to the text confirmation.

Dymo Stamps and Dymo Printable Postage
Incident Report for Endicia Statuspage
Resolved
This incident has been resolved.
Posted Jun 14, 2019 - 09:59 PDT
Update
Dymo Stamps and Dymo Printable Postage issue has been resolved.
Posted Jun 14, 2019 - 08:31 PDT
Update
Update on Issue: If you encounter an error prompt in the process of printing - please click OK to proceed.
Posted Jun 14, 2019 - 06:54 PDT
Investigating
At the present time our Engineering team is investing reports of errors when attempting to print or when logging in to both Dymo Stamps and Dymo Printable Postage.
Posted Jun 14, 2019 - 06:50 PDT
This incident affected: Endicia Online (Printing postage using a Web Browser) and Endicia Downloadable (Print postage using our Windows application).