System Status

Welcome to the Endicia System Status page, our home for real-time information on service alerts. If there are any interruptions in service, a note will be posted here.

Subscribing to Email & SMS Updates—Please “confirm” your subscription by responding to the email we send after you sign up for alerts. This email will be coming from noreply@statuspage.io. To receive alert texts on your mobile phone, you will also need to reply back “YES” to the text confirmation.

Customer using Dazzle interface - receiving prompt to update to a current version
Incident Report for Endicia Status page
Resolved
Endicia Engineers have fixed the postage printing issue and all systems are functioning normally. Thanks for your patience!
Posted Oct 24, 2019 - 11:50 PDT
Investigating
At the present time our Engineers are investigating a reported issue where the Dazzle interface is prompting for an update due to discount rates not being supported. Please disregard this message while we investigate this issue further.
Posted Oct 24, 2019 - 11:29 PDT
This incident affected: Endicia DAZzle (Print postage with downloadable software for the PC).