System Status

Welcome to the Endicia System Status page, our home for real-time information on service alerts. If there are any interruptions in service, a note will be posted here.

Subscribing to Email & SMS Updates—Please “confirm” your subscription by responding to the email we send after you sign up for alerts. This email will be coming from noreply@statuspage.io. To receive alert texts on your mobile phone, you will also need to reply back “YES” to the text confirmation.

Endicia Undergoing Scheduled Maintenance on Saturday, March 7, (9 to 10PM PST)
Incident Report for Endicia Status page
Resolved
Endicia Engineers have completed the scheduled maintenance and all systems are functioning normally. Thanks for your patience!
Posted Mar 09, 2020 - 09:38 PDT
Investigating
The Endicia service will be undergoing scheduled maintenance Saturday, March 7, from 9-10pm (PST). During this time you may experience brief periods of intermittent service disruption. We apologize for any inconvenience.
Posted Mar 06, 2020 - 11:50 PST
This incident affected: Endicia Online (Printing postage using a Web Browser), Endicia Downloadable (Print postage using our Windows application), Endicia DAZzle (Print postage with downloadable software for the PC), Endicia for Mac (Print postage with downloadable software for Mac), Endicia API (Endicia Label Server), Endicia Reporting Tools (Postage History, Refunds, SCAN Forms), and Dial-A-ZIP API.