System Status

Welcome to the Endicia System Status page, our home for real-time information on service alerts. If there are any interruptions in service, a note will be posted here.

Subscribing to Email & SMS Updates—Please “confirm” your subscription by responding to the email we send after you sign up for alerts. This email will be coming from noreply@statuspage.io. To receive alert texts on your mobile phone, you will also need to reply back “YES” to the text confirmation.

USPS Tracking Error
Incident Report for Endicia Statuspage
Resolved
On January 12, 2024, the United States Postal Service identified a subset of shipments incorrectly flagged as unpaid. The USPS tracking pages for these shipments displayed a message saying that the packages were identified as fraudulent and could be seized.

The USPS has undertaken efforts to remove this messaging from tracking pages and to release incorrectly flagged packages for delivery. Any incorrect messages remaining on tracking pages will be removed in the coming days.
Posted Jan 19, 2024 - 14:56 PST
Update
We are still in in communication with USPS regarding reports of some tracking numbers on the USPS website being displayed as "counterfeit" postage. We are working with the USPS to resolve this issue and ensure that all proper and valid packages are delivered to customers.
Posted Jan 17, 2024 - 12:18 PST
Investigating
We are still in communication with USPS regarding reports of some tracking numbers on the USPS website being displayed as "counterfeit" postage. Our team is currently investigating this further and working towards a solution. We appreciate your patience!
Posted Jan 17, 2024 - 10:54 PST
This incident affected: Endicia Online (Printing postage using a Web Browser), Endicia Downloadable (Print postage using our Windows application), and Endicia API (Endicia Label Server).