System Status

Welcome to the Endicia System Status page, our home for real-time information on service alerts. If there are any interruptions in service, a note will be posted here.

Subscribing to Email & SMS Updates—Please “confirm” your subscription by responding to the email we send after you sign up for alerts. This email will be coming from noreply@statuspage.io. To receive alert texts on your mobile phone, you will also need to reply back “YES” to the text confirmation.

Issues Printing Postage
Incident Report for Endicia Status page
Resolved
Endicia Engineers have fixed the postage printing issue and all systems are functioning normally. Thanks for your patience!
Posted 9 months ago. Aug 20, 2018 - 12:00 PDT
Investigating
Endicia Engineers are investigating an issue that may temporarily affect some of our customers' ability to print postage and shipping labels using our Label Server platform. Sorry for the inconvenience – we'll have a solution for this soon!
Posted 9 months ago. Aug 20, 2018 - 09:34 PDT
This incident affected: Endicia API (Endicia Label Server).