System Status

Welcome to the Endicia System Status page, our home for real-time information on service alerts. If there are any interruptions in service, a note will be posted here.

Subscribing to Email & SMS Updates—Please “confirm” your subscription by responding to the email we send after you sign up for alerts. This email will be coming from noreply@statuspage.io. To receive alert texts on your mobile phone, you will also need to reply back “YES” to the text confirmation.

Postage Purchase Errors
Incident Report for Endicia Statuspage
Resolved
This incident has been resolved.
Posted Feb 10, 2020 - 08:00 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 10, 2020 - 07:44 PST
Investigating
Endicia Engineers have identified an issue that may temporarily affect some of our customers' ability to purchase postage. Sorry for the inconvenience – we'll have a solution for you soon!
Posted Feb 10, 2020 - 07:10 PST
This incident affected: Endicia Reporting Tools (Postage History, Refunds, SCAN Forms).