System Status

Welcome to the Endicia System Status page, our home for real-time information on service alerts. If there are any interruptions in service, a note will be posted here.

Subscribing to Email & SMS Updates—Please “confirm” your subscription by responding to the email we send after you sign up for alerts. This email will be coming from noreply@statuspage.io. To receive alert texts on your mobile phone, you will also need to reply back “YES” to the text confirmation.

USPS Temporarily Suspends Service on 1/9/25
Incident Report for Endicia Statuspage
Resolved
This incident has been resolved.
Posted Jan 10, 2025 - 15:02 PST
Monitoring
In honor of former President, Jimmy Carter, USPS will observe a National Day of Observance on Thursday, January 9th. On this day, mail deliveries, retail services, and administrative office activity will be temporarily suspended. Commercial drop-offs will continue to be accepted and processed and limited package delivery will occur to prevent impacts.

Regular operations will resume on Friday, January 10th. More info: https://postalpro.usps.com/node/13715
Posted Jan 07, 2025 - 15:26 PST