System Status

Welcome to the Endicia System Status page, our home for real-time information on service alerts. If there are any interruptions in service, a note will be posted here.

Subscribing to Email & SMS Updates—Please “confirm” your subscription by responding to the email we send after you sign up for alerts. This email will be coming from noreply@statuspage.io. To receive alert texts on your mobile phone, you will also need to reply back “YES” to the text confirmation.

Print History Unexpected Technical Problem
Incident Report for Endicia Status page
Resolved
Endicia Engineers have fixed the technical issue and all systems are functioning normally. Thanks for your patience!
Posted Mar 03, 2020 - 14:39 PST
Investigating
Endicia Engineers have identified an issue that may affect some of our customers' ability to see transactions in their Printed Postage History Report, Refund Section, and SCAN Form. Sorry for the inconvenience – we’ll have a solution for this soon!
Posted Mar 03, 2020 - 14:32 PST
This incident affected: Endicia Reporting Tools (Postage History, Refunds, SCAN Forms).