System Status

Welcome to the Endicia System Status page, our home for real-time information on service alerts. If there are any interruptions in service, a note will be posted here.

Subscribing to Email & SMS Updates—Please “confirm” your subscription by responding to the email we send after you sign up for alerts. This email will be coming from noreply@statuspage.io. To receive alert texts on your mobile phone, you will also need to reply back “YES” to the text confirmation.

Unexpected Technical Problem
Incident Report for Endicia Status page
Resolved
Endicia Engineers have reported that all systems are functioning normally. Thanks for your patience!
Posted 7 months ago. Jun 20, 2018 - 13:14 PDT
Update
We have identified that the issue is with a 3rd party vendor. We will continue to monitor and update this page as we learn more.
Posted 7 months ago. Jun 20, 2018 - 12:40 PDT
Identified
Endicia is currently experiencing a technical issue that we are working to resolve. Our engineering team is working to resolve this issue as quickly as possible. We'll share another update shortly.
Posted 7 months ago. Jun 20, 2018 - 12:25 PDT
This incident affected: Endicia Online (Printing postage using a Web Browser), Endicia Downloadable (Print postage using our Windows application), Endicia DAZzle (Print postage with downloadable software for the PC), Endicia for Mac (Print postage with downloadable software for Mac), Endicia API (Endicia Label Server), and Endicia Reporting Tools (Postage History, Refunds, SCAN Forms).