System Status

Welcome to the Endicia System Status page, our home for real-time information on service alerts. If there are any interruptions in service, a note will be posted here.

Subscribing to Email & SMS Updates—Please “confirm” your subscription by responding to the email we send after you sign up for alerts. This email will be coming from noreply@statuspage.io. To receive alert texts on your mobile phone, you will also need to reply back “YES” to the text confirmation.

Unexpected Technical Problem
Incident Report for Endicia Status page
Resolved
The inability to print postage via BigCommerce has been resolved. Thank you for your patience.
Posted 7 days ago. Nov 05, 2018 - 17:41 PST
Identified
Endicia is aware of the issue reported by BigCommerce users unable to generate labels. We are in contact with BigCommerce to identify the cause of the issue. We'll share another update shortly.
Posted 7 days ago. Nov 05, 2018 - 14:16 PST
This incident affected: Endicia API (Endicia Label Server).