System Status

Welcome to the Endicia System Status page, our home for real-time information on service alerts. If there are any interruptions in service, a note will be posted here.

Subscribing to Email & SMS Updates—Please “confirm” your subscription by responding to the email we send after you sign up for alerts. This email will be coming from noreply@statuspage.io. To receive alert texts on your mobile phone, you will also need to reply back “YES” to the text confirmation.

Unexpected Technical Problem
Incident Report for Endicia Status page
Resolved
Endicia Engineers have fixed the technical issue and all systems are functioning normally. Thanks for your patience!
Posted Jan 30, 2020 - 14:40 PST
Investigating
Endicia.com is currently experiencing a technical issue with our online store. We are working to resolve and our engineering team is working to resolve this issue as quickly as possible. We’ll share another update shortly.
Posted Jan 30, 2020 - 14:26 PST