System Status

Welcome to the Endicia System Status page, our home for real-time information on service alerts. If there are any interruptions in service, a note will be posted here.

Subscribing to Email & SMS Updates—Please “confirm” your subscription by responding to the email we send after you sign up for alerts. This email will be coming from noreply@statuspage.io. To receive alert texts on your mobile phone, you will also need to reply back “YES” to the text confirmation.

Postage Purchase Delays Via USPS EPS
Incident Report for Endicia Status page
Resolved
Endicia Engineers have received confirmation from the 3rd party service and fixed the postage purchase issue thru USPS EPS and all systems are functioning normally. Thanks for your patience!
Posted Nov 09, 2020 - 07:01 PST
Investigating
Endicia Engineers have identified an issue that may temporarily affect some of our customers' ability to purchase postage via EPS. USPS EPS Web API is currently impacted and we are waiting on this 3rd party service to be restored before payment activity will return to normal.
Posted Nov 06, 2020 - 14:19 PST
This incident affected: Endicia Online (Printing postage using a Web Browser), Endicia Downloadable (Print postage using our Windows application), Endicia DAZzle (Print postage with downloadable software for the PC), Endicia for Mac (Print postage with downloadable software for Mac), and Endicia API (Endicia Label Server).