System Status

Welcome to the Endicia System Status page, our home for real-time information on service alerts. If there are any interruptions in service, a note will be posted here.

Subscribing to Email & SMS Updates—Please “confirm” your subscription by responding to the email we send after you sign up for alerts. This email will be coming from noreply@statuspage.io. To receive alert texts on your mobile phone, you will also need to reply back “YES” to the text confirmation.

Postage Purchase Delays
Incident Report for Endicia Status page
Resolved
Endicia Engineers have verified the third party issue affecting postage purchases has been resolved and all systems are functioning normally. Thanks for your patience!
Posted 13 days ago. Jan 03, 2019 - 12:57 PST
Update
Our third party payment gateway is still investigating the purchase delays. Sorry for the inconvenience – we'll have a solution for you soon!
Posted 13 days ago. Jan 03, 2019 - 10:18 PST
Update
We are continuing to investigate this issue.
Posted 13 days ago. Jan 03, 2019 - 09:22 PST
Investigating
Endicia Engineers have identified an issue with a third party that may temporarily affect some of our customers' ability to purchase postage. Sorry for the inconvenience – we'll have a solution for you soon!
Posted 13 days ago. Jan 03, 2019 - 09:21 PST