System Status

Welcome to the Endicia System Status page, our home for real-time information on service alerts. If there are any interruptions in service, a note will be posted here.

Subscribing to Email & SMS Updates—Please “confirm” your subscription by responding to the email we send after you sign up for alerts. This email will be coming from noreply@statuspage.io. To receive alert texts on your mobile phone, you will also need to reply back “YES” to the text confirmation.

Login Issues
Incident Report for Endicia Status page
Resolved
Endicia Engineers have resolved the log in issue. We apologize for the inconvenience and thank you for your patience. If you are still having issues, please contact us.
Posted Dec 15, 2021 - 08:30 PST
Investigating
Our Engineers have identified an issue that may affect some of our customers' ability to login into their Endicia account. We are working to quickly resolve this issue and will provide an update when it is available. We apologize for the inconvenience.
Posted Dec 15, 2021 - 08:01 PST
This incident affected: Endicia Online (Printing postage using a Web Browser), Endicia Downloadable (Print postage using our Windows application), Endicia DAZzle (Print postage with downloadable software for the PC), Endicia for Mac (Print postage with downloadable software for Mac), and Endicia API (Endicia Label Server).