System Status

Welcome to the Endicia System Status page, our home for real-time information on service alerts. If there are any interruptions in service, a note will be posted here.

Subscribing to Email & SMS Updates—Please “confirm” your subscription by responding to the email we send after you sign up for alerts. This email will be coming from noreply@statuspage.io. To receive alert texts on your mobile phone, you will also need to reply back “YES” to the text confirmation.

Postage Purchase Delays
Incident Report for Endicia Status page
Resolved
Endicia Engineers have fixed the postage printing issue. We apologize for the inconvenience and thank you for your patience. If you are still having issues, please contact us.
Posted Jul 28, 2021 - 13:20 PDT
Investigating
Endicia Engineers have identified an issue that may affect some of our customers' ability to purchase postage. We are working to quickly resolve this issue and will provide an update as soon as it’s available. We apologize for the inconvenience.
Posted Jul 28, 2021 - 11:59 PDT
This incident affected: Endicia Online (Printing postage using a Web Browser) and Endicia API (Endicia Label Server).