System Status

Welcome to the Endicia System Status page, our home for real-time information on service alerts. If there are any interruptions in service, a note will be posted here.

Subscribing to Email & SMS Updates—Please “confirm” your subscription by responding to the email we send after you sign up for alerts. This email will be coming from noreply@statuspage.io. To receive alert texts on your mobile phone, you will also need to reply back “YES” to the text confirmation.

Postage Purchase Delays
Incident Report for Endicia Status page
Resolved
Endicia Engineers have fixed the postage purchase issue and all systems are functioning normally. Thanks for your patience!
Posted Jul 07, 2020 - 13:19 PDT
Investigating
Endicia Engineers have identified an issue that may temporarily affect some of our customers' ability to purchase postage. Sorry for the inconvenience – we'll have a solution for you soon!
Posted Jul 07, 2020 - 12:54 PDT
This incident affected: Endicia Online (Printing postage using a Web Browser), Endicia Downloadable (Print postage using our Windows application), and Endicia DAZzle (Print postage with downloadable software for the PC).