System Status

Welcome to the Endicia System Status page, our home for real-time information on service alerts. If there are any interruptions in service, a note will be posted here.

Subscribing to Email & SMS Updates—Please “confirm” your subscription by responding to the email we send after you sign up for alerts. This email will be coming from noreply@statuspage.io. To receive alert texts on your mobile phone, you will also need to reply back “YES” to the text confirmation.

Orders Unexpected Technical Problem
Incident Report for Endicia Status page
Resolved
Endicia Engineers have fixed the issue and all orders are being imported in real-time. Endicia is now functioning normally. Thanks for your patience!
Posted 2 months ago. Mar 13, 2019 - 12:17 PDT
Identified
Endicia Engineers have identified an issue that may delay some of our customers' ability to access orders from the Orders section online. Sorry for the inconvenience – we'll have a solution for this soon!
Posted 2 months ago. Mar 13, 2019 - 11:50 PDT
This incident affected: Endicia Online (Printing postage using a Web Browser).