System Status

Welcome to the Endicia System Status page, our home for real-time information on service alerts. If there are any interruptions in service, a note will be posted here.

Subscribing to Email & SMS Updates—Please “confirm” your subscription by responding to the email we send after you sign up for alerts. This email will be coming from noreply@statuspage.io. To receive alert texts on your mobile phone, you will also need to reply back “YES” to the text confirmation.

Login Issues
Incident Report for Endicia Status page
Resolved
Endicia Engineers have fixed the technical issue and all systems are functioning normally. Thanks for your patience!
Posted 2 months ago. Nov 09, 2018 - 06:59 PST
Identified
Our Engineers have identified an issue that may temporarily affect some of our customers' ability to login into the Endicia software. Sorry for the inconvenience – we'll have a solution for this soon!
Posted 2 months ago. Nov 09, 2018 - 06:45 PST
This incident affected: Endicia Downloadable (Print postage using our Windows application), Endicia DAZzle (Print postage with downloadable software for the PC), Endicia for Mac (Print postage with downloadable software for Mac), and Endicia API (Endicia Label Server).