System Status

Welcome to the Endicia System Status page, our home for real-time information on service alerts. If there are any interruptions in service, a note will be posted here.

Subscribing to Email & SMS Updates—Please “confirm” your subscription by responding to the email we send after you sign up for alerts. This email will be coming from noreply@statuspage.io. To receive alert texts on your mobile phone, you will also need to reply back “YES” to the text confirmation.

Issues Printing Postage
Incident Report for Endicia Statuspage
Resolved
This incident has been resolved.
Posted Mar 21, 2023 - 08:11 PDT
Investigating
Endicia Engineers have identified an issue that may temporarily affect some of our customers' ability to print postage and shipping labels. We are working to quickly resolve this issue and will provide an update when it is available. We apologize for the inconvenience.
Posted Mar 21, 2023 - 08:01 PDT
This incident affected: Endicia Online (Printing postage using a Web Browser), Endicia Downloadable (Print postage using our Windows application), Endicia DAZzle (Print postage with downloadable software for the PC), Endicia for Mac (Print postage with downloadable software for Mac), and Endicia API (Endicia Label Server).