System Status

Welcome to the Endicia System Status page, our home for real-time information on service alerts. If there are any interruptions in service, a note will be posted here.

Subscribing to Email & SMS Updates—Please “confirm” your subscription by responding to the email we send after you sign up for alerts. This email will be coming from noreply@statuspage.io. To receive alert texts on your mobile phone, you will also need to reply back “YES” to the text confirmation.

Unexpected Technical Problem | Endicia Label Server Slow/Timeouts
Incident Report for Endicia Statuspage
Resolved
Endicia Engineers have fixed the technical issue and all systems are functioning normally. Thanks for your patience!
Posted May 06, 2019 - 10:18 PDT
Update
We are continuing to work on a fix for the issue.
Posted May 06, 2019 - 09:45 PDT
Identified
Endicia is currently experiencing a technical issue that we are working to resolve. Our engineering team is working to resolve this issue as quickly as possible. We'll share another update shortly.
Posted May 06, 2019 - 08:57 PDT
This incident affected: Endicia API (Endicia Label Server).